Topic: FW 21 pushed

A hotfix firmware 21 was pushed to address issues reported by customers in the field particularly with the UI lock-out during the connecting phase, and the command line issue with NeTVBrowser (as reported by dlovy).

7BAA 2E53 01C1 DCFF 497B  E7F0 9699 A303 78F0 D9B9

Re: FW 21 pushed

Since my device seems stuck in a connecting mode - How do I force the update to 21?


Re: FW 21 pushed

You just need to leave the device running as is. It will update automatically.

Just to be sure, you should power the device from a computer USB port, SSH will be enabled automatically.
Then, verify that the device has Internet access.

Re: FW 21 pushed

It's been running for several hours.  SSH is working and I'm able to load other websites.

Do I need to have the local UI running or the update to work?

Can I force the update?


Re: FW 21 pushed

yes, do

mount -o remount,rw /
touch /test-updates
mount -o remount,ro /

should immediately trigger an update.

7BAA 2E53 01C1 DCFF 497B  E7F0 9699 A303 78F0 D9B9

Re: FW 21 pushed

btw, i've seen a couple v20 units go to v21 so far, so please do let me know if you see something odd going on. in /tmp there should be a series of log files that will elucidate any errors.

7BAA 2E53 01C1 DCFF 497B  E7F0 9699 A303 78F0 D9B9

Re: FW 21 pushed

Sorry, couldn't get to this until this morning.

I ran the commands you listed, seemed to work, however -

the FW version is still listed as 20
the startup hangs on connecting...
NeTVBrowser does not work

Here is the transcript from the restart script


Last login: Fri Oct 28 19:32:05 2011 from
root@chumby-silvermoon-netv:~# mount -o remount,rw /
root@chumby-silvermoon-netv:~# touch /test-updates
root@chumby-silvermoon-netv:~# mount -o remount,ro /
root@chumby-silvermoon-netv:~# /usr/bin/
gpg: Signature made Fri Oct 28 23:18:08 2011 GMT-5 using RSA key ID 50572998
gpg: NOTE: trustdb not writable
gpg: Good signature from "chumby industries PTE LTD signing authority 1 (This ke  y is used to sign updates.) <>"
gpg: WARNING: This key is not certified with a trusted signature!
gpg:          There is no indication that the signature belongs to the owner.
Primary key fingerprint: B979 B055 4E8D C30D FDF9  027F DFDE FC11 5057 2998
+ exec
+ grep -q builder_silvermoon_netv /etc/opkg/arch.conf /etc/opkg/chumby.conf /etc  /opkg/local-all-feed.conf /etc/opkg/local-armv5te-feed.conf /etc/opkg/local-chum  by-silvermoon-netv-feed.conf /etc/opkg/opkg.conf /etc/opkg/opkg.conf-opkg /etc/o  pkg/secring.gpg /etc/opkg/trustdb.gpg /etc/opkg/trusted.gpg
+ ls -l /bin/sh
+ grep -q bash
+ grep -q 'option offline_root /' /etc/opkg/opkg.conf
++ md5sum /usr/lib/
++ cut '-d ' -f1
+ '[' xbbae7819c5bc8ce5a79aff54ee99ff98 = x773860982b032b3840271f444bd4141e ']'
+ logger -t update 'Downloading package list...'
+ opkg update
++ opkg list-installed kernel-modules
++ wc -l
+ '[' 2 -gt 0 ']'
+ logger -t update 'Attempting to remove kernel-modules'
+ opkg upgrade task-machine-base
+ opkg remove kernel-modules
+ opkg list-upgradable
++ wc -l /tmp/
++ cut '-d ' -f1
+ '[' x6 = x ']'
+ '[' 6 -le 0 ']'
+ logger -t update 'Fetching 6 upgraded packages.'
++ chumby_version -f
+ fwver=20
+ '[' 20 -lt 20 ']'
+ match='NeTVBrowser -qws UpdateDone &'
+ replacement='curl -d "cmd=javascript\&value=window.status=\'\''<xml\><cmd>Upda  teDone<\/cmd><value>0<\/value><\/xml>\'\''" http\:\/\/localhost\/bridge \nif \[   -z "$(pidof NeTVBrowser)" \];\nthen\n\t\/etc\/init.d\/chumby-netvbrowser restart  \nfi'
+ mount -o remount,rw /
+ sed -i 's/NeTVBrowser -qws UpdateDone &/curl -d "cmd=javascript\&value=window.  status=\'\''<xml\><cmd>UpdateDone<\/cmd><value>0<\/value><\/xml>\'\''" http\:\/\  /localhost\/bridge \nif \[ -z "$(pidof NeTVBrowser)" \];\nthen\n\t\/etc\/init.d\  /chumby-netvbrowser restart\nfi/g' /usr/bin/
+ sync
+ mount -o remount,ro /
+ curl -d 'cmd=javascript&value=window.status='\''<xml><cmd>UpdateCount</cmd><va  lue>6</value></xml>'\''' http://localhost/bridge
  % Total    % Received % Xferd  Average Speed   Time    Time     Time  Current
                                 Dload  Upload   Total   Spent    Left  Speed
100   196  100   110  100    86   1644   1285 --:--:-- --:--:-- --:--:--  2200
+ egrep -q '^(kernel|u-boot)' /tmp/
+ opkg --cache /var/lib/opkg/tmp --download-only upgrade
+ logger -t update 'Update downloaded successfully, and are ready to be installe  d.'
+ '[' 20 -lt 20 ']'
+ curl -d 'cmd=javascript&value=window.status='\''<xml><cmd>UpdateReady</cmd><va  lue>6\|\~\|0</value></xml>'\''' http://localhost/bridge
  % Total    % Received % Xferd  Average Speed   Time    Time     Time  Current
                                 Dload  Upload   Total   Spent    Left  Speed
100   203  100   110  100    93   2134   1804 --:--:-- --:--:-- --:--:--  2291
+ '[' 0 -eq 1 ']'
+ logger -t update 'Script finished'
+ do_cleanup
+ rm -f /tmp/ /tmp/ /tmp/
+ exit 0


here is the output from hello

<hwver><cpi version='1.0'>
    <response type="hwvr" result="success">00000000000000000000000000060000</response>
    <interface if="wlan0" up="true" link="true" ip="" broadcast="" netmask="" gateway="" nameserver1="" nameserver2="">

Re: FW 21 pushed

The firmware doesn't seem to be updated at all.

Did you see the update UI come up?

Re: FW 21 pushed

Well, now it seems to work!


thanks again.

Re: FW 21 pushed

It was strange,  I never saw the on screen UI stuff come up.  the transcript was from the SSH session.

I ran hello and could see the fw version still at 20 and NeTVBrowser not working.

I then did a full cold reboot.

Still no luck.  Same result.

Went to the system info screen and there was no fw filled in and the ip address was

very strange, not from my router.  thought maybe I picked up a neighbors wifi.  reset the wifi network to mine.  still no joy.

Went and made my forum post.  Glanced up and the twitter ticker was scrolling across the bottom. I haven't seen that in days.

Well, suddenly every thing is fine.  FW version correct, NeTVBrowser working and my cProxy hack is overwritten.

It's all good.

Re: FW 21 pushed

Congrat, you have firmware 21. yay! smile
All issues with NeTVBrowser & glitches in HTTP API are resolved in firmware 21. is the IP of NeTV when it's in Access Point mode.
Not sure why you have that IP while having a rolling ticker at the same time (which means Internet is accessible).

We've kind of seen this strange behavior with the update recently, but yet to clearly reproduce & confirm the problem.
Back to drawing board for us.

Re: FW 21 pushed

Here's what I think happened.

When I checked the IP address, I happened to catch it in Access Point mode (didn't know what that was).

I was confused.  It then switched back to my router and since the update was now complete the ticker just started working and all was well with the world.

BTW.  I sent bunnie some instructions on how to run our system.  Should I send them to you as well.  Don't know what part of the planet you and he are working from.

thanks again,

Re: FW 21 pushed

dan, I've got your instructions from bunnie.

Did you ever pull the power when root is mounted in read-write mode?
This could explain why the unit didn't update correctly before reboot, and sort-of fixed when you performed a cold reboot.

Re: FW 21 pushed

I could have easily done that.  I tend to work in read/write mode most of the time.

As we are testing on more and more units, we are about to roll out some code that will let each box be uniquely addressable.  Right now, if you make a change on the web site, all the boxes see it and the first box that gets there resets the command creating puzzling behavior.

We are also adding the capability to add install our code directly from our server, without having to ssh in.  Much like we do with the .swf files.

Send me your email address and I'll copy you the stuff I send to bunnie.  Please do not hesitate to critique how we are implementing all this.