Topic: Interesting Alarm Bug

This morning when my alarm went off, I hit the top button to make it snooze for another ten minutes. Worked fine. The alarm went off once again after the ten minutes as expected. I hit the top button again to snooze it once more but I hit it twice instead of once. The Bugle alram sound did not shut off and the device went to the control panel. I couldn't for the life of me shut the alarm sound off (disabled that alarm, changed the sound time, nothing seemed to work, I even tried to wait out the 30 min sounding time with mute on of course). I had to restart the chumby in order to make the alarm go off.

Anyone see this happening on their chumbys? First time it has happened to me, although I didn't have time to recreate the conditions since I had to go to work.

Also, I have found that the chumby likes to lock up when it loses connection and won't change to the on board clock. Is this a regular occurence?

Re: Interesting Alarm Bug

On the first issue, that sounds like a race condition, and I'll see If I can figure out what's going on there.

On the second issue, we've got a Control Panel in QA that attempts to mitigate the problem of failing to switch to the onboard clock in the event of connection loss.  The biggest issue is actually detecting the dropped connection from Flash.

Re: Interesting Alarm Bug

I am not sure if the problem I have with the clock is this second issue. Usually, at night, I set up the alarm clock for the next morning, put the chumby on night mode, and turn-off my wireless router.
When the alarm goes off next morning, I turn it off and, as configured in the alarm, my Chumby leaves the "night mode". The problem is that, as my wireless router is off, the chumby clock freezes and keeps displaying the time the alarm went off (the time is not updated). I know this is not a major issue as the workaround is to leave the wireless router on.

Is there any other solution for this issue?