Topic: Problem Finding the Network

I have the 3.5" Infocast device and it has a problem finding any networks.

Once it does connect, it will stay connected for months with no problems, but if the power goes out, it will not reconnect without many, many tries, power cycling, etc. Sometimes it takes many tries over days before it will find any network to connect to.

When trying to connect to an existing connection, I get the familiar "wlan(0) device not found ..." screen.

If I try to create a new connection, no networks are found. The unit is in the same room as the router and several networks should show up as they do on phones and tablets in the house. So it is not the network.

At one point I thought it was a bad connection in the unit, so after taking it apart and reseating the small PCB, the result was the same. The next day, after power cycling it several times, it finally connected and worked for several months before another power outage today.

Any ideas?

Re: Problem Finding the Network

I used to suffer from this kind of thing, unfortunately some WiFi access points just don't seem to be very compatible with the Chumby. I wanted to replace the AP anyway to provide service on the 5GHz band as well, and my newer AP (a Linksys WRT1200AC) has no problem talking to my Chumbies.

Re: Problem Finding the Network

In the screen where it would normally show the AP list, what does it display for the MAC for the adapter?

The error message "device not found" typically means that it's having trouble talking to the USB dongle - it's possible the internal USB port is having problems.  If you don't mind opening the device again, try removing the dongle and plugging it into the external USB port.

Re: Problem Finding the Network

The MAC address is all zeros.

I opened it up again and tried the dongle in the external port and the result was the same (could not find a network and MAC address of all zeros).

I also tried another router, an older style, and there was no change (could not find any networks)...

Re: Problem Finding the Network

OK, it sounds like the wifi dongle itself is having a problem, if it showed a MAC of all zeroes in both ports.  It's less likely that both USB ports went bad.  You might also be able to confirm that by plugging the dongle into a laptop and see if it's recognized.

I'll see if I can dig up a replacement in storage - please contact me though the support email link on the main site.