1 (edited by uphiearl 2011-05-03 13:03:31)

Topic: USB problems

I got a Chumby classic at Best Buy for $19 on the as is cart !
Seams to work with my terminal program and an FTDI USB cable connected to the TX/RX/GND pins inside.
I can put .img files on a 1 to 4gb SD card ok with Win7 and the Win32DiskImager program.
So far so good !!

I can't seam to get the wireless or the other usb port to work.
I tried 6 different usb drives formatted in FAT32 clean with just the tgz files or the update1 update2 folders on them at root but the update selection wifi or usb doesn't light up, just grayed out.

That is why I used the .img files (2 different ones) and windows to update an SD card.
They are rom-falconwing.img and rom-chumby-falconwing-chumby-starter-image.img
Both .img files work fine.

The Wi-Fi usb dongle works fine on my windows computer ! It is the RT73 from the Chumby. So we rule out a bad wifi card.
I tried a usb keyboard (2 different ones) and they don't seam to work.
I measured the voltage at the 2 usb ports and both are 5.17 vdc. I have not looked at the data lines with a scope yet.

On boot up I don't think I see a driver for the RT73 load up.
I think I do see the usbhub drivers load ok.
I don't see a ttyusb in the /dev dir.
I do have a usbdev1.1_ep00 and a usbdev1.1_ep81 in the /dev dir.

When I do a iwconfig I get   lo     no wireless extensions
when I do a iwlist wlan0 scan I get    wlan0   Interface doesn't support scanning.
Same with the usbdev1.1_ep00 or 81
So, the usb interfaces don't seem to exist.

Any other things I can try ?


Re: USB problems

On examination of the /psp directory there is no network.conf file. I suspect other files are not there also.

Re: USB problems

The "chumby classic" is leather-encased unit - are you sure you got that at Best Buy?

4 (edited by uphiearl 2011-05-03 14:11:25)

Re: USB problems

It is black plastic with a knob on the left side. Chumby 1 maybe ? On bootup it has a green screen that says insignia.
I found a picture and info... it is a Insignia Infocast 3.5"

BTW Can I get .img files of software because the usb port don't work ? I can load them.

Re: USB problems

Wow, if you see another one for $19, let me know.  I'd buy two or three at that price!

Linux Guy - Occasional Chumby Hacker

Re: USB problems

There was only one! Darn
I still need some .img files tho.