1 (edited by illjoshlli 2008-08-20 20:02:15)

Topic: Backup Alarm goes off when turning on chumby

In the morning I use the quick alarm and two custom alarms (two custom alarms have the backup alarm OFF). Once I finally decide to get out of bed (after snoozing a bunch) I shut the Chumby off. I never actually shut the alarm off, only snooze it. When I get home at night and turn it on; after a few min. the back up alarm will go off. It’s extremely annoying, and happens every time.

software version 2.7.16

Re: Backup Alarm goes off when turning on chumby

Right - this is the correct behavior.  The backup alarm system shows that an alarm was scheduled to go off sometime in the past but didn't, so it fires.

The only way to get rid on a backup alarm is to turn it off, or dismiss it - that's part of the "reliability" of the alarm.

We've made it much easier to turn of alarms directly from the alarm list - to kill a snoozed alarm, simply turn it off then back on again.

Re: Backup Alarm goes off when turning on chumby

The custom alarms give you the option to not use the backup alarm; whereas the quick alarm does not; yet it seems to have the backup alarm associated to it. So, if I don’t want to use the backup alarm functionality I can’t shut it off for the quick alarm meaning I can no longer use the quick alarm functionality.

Also, why would anyone want the backup alarm to fire 8-12 hours later? I like the idea of the backup alarm; but it would make since to not fire it after a certain amount of time. Unless you’re using the alarm as a ‘reminder’ I have a hard time thinking of reasons you would want the back alarm to fire hours later.

- Josh

Re: Backup Alarm goes off when turning on chumby

Perhaps someone from Product Management will chime in.

Re: Backup Alarm goes off when turning on chumby

If you want to permanently disable the backup alarm, you can create a debugchumby script that contains:

rm -f /psp/ifalarm

If you prefer not to have a USB dongle attached to the device to disable the back-up alarm, you can insert the rm -f /psp/ifalarm command before the /bin/chumbalarmd statement in the init script by using the running something at boot without debugchumby method.  However, please only use this method if you know -exactly- what you're doing, as you can cause a permanent boot failure which cannot be resolved without restoring factory settings or applying a USB firmware update.

A couple other things that may be of interest regarding the back-up alarm:

1. You can override the back-up alarm audio duration (though the screen will stay up until dismissed) by setting /psp/backup_alarm_duration in seconds.  Default is 1800 seconds (30 minutes).

2. You can override the back-up volume by setting /psp/backup_alarm_volume to a value from 0-100.  Volume defaults to 100.