Topic: chumby classic - no boot


i rebooted my chumby this morning and it doesn't came up anymore. It remains stuck at the step where the chumby icon is "dancing" and the text "chumby (R)" is displayed.
After reading a lot of posts having the same issue, i tried to get in the special options but it stucked even here.
I succeeded 1 time and i did the update from here m/viewtopic.php?pid=46109#p46109 (please correct the link at .com - it was not allowed to post links, why?) via USB stick. The flash process was OK and i came to WLAN setup but chumby never got into the WLAN after the password was entered.
So i reboot the device and now i am at the beginning with now chance to get again into the special option menu.

Could be that the SD card is damaged ? (too many write cycles)

Anybody that can help me? Thanks

Re: chumby classic - no boot

If this is a classic, there is no SD, it uses NOR Flash.

The chumby does not write to the storage except for firmware updates, with the exception of a small partition mounted as /psp.  That partition only stores setting information such as wifi config, volume, etc that would need to survive a reboot, and they are only written if there's an actual change.

Of course even with that little amount of writing, over a very long time (some of these devices are now 15 years old) it's possible for the Flash to have run out of spare block to replace block that have gone bad.

Based on the symptoms, it really seems more like an issue with the Wifi - even if "special options" mode, it will still try to set up the network in case there's an over the air firmware update available.

As to what to do, one thing to try is to make a simple script on a USB dongle to explicitly delete the wifi settings from /psp so it won't try to connect.  You might also try tracking down compatible Ethernet dongle to provide an alternative network to get the device up and running enough to investigate what might be going on.

One rare thing that we've seen a couple of times over the years is the /psp partition getting corrupted, and needing to be reformatted.  I think there are some posts o this forum on how to do that.

Re: chumby classic - no boot

what i found out is that the devices didn't get stuck but it takes ages to boot up (2-3 hours).
sometimes it can't login into the wlan after power on, then i have to reboot...and wait 2-3 hours, then is working.
i tried also reflashing with the latest fw and also with the one fw before, but it behaves the same.
the device is about 15 years old, jeah

Re: chumby classic - no boot

Wow, I can't think of any reason why they should take that long to boot - what's it's doing at that port of the boot process is trying to connect to the local network, typically association with the Wifi AP and then getting an IP via DHCP.

As mentioned before, I'd try to locate a compatible Ethernet dongle (see the Wiki), and see if the boot process speeds up.