Please read this post carefully and in its entirety before doing anything - almost everyone that has had a problem has missed something we've explicitly covered here.

As many of you have discovered, some Sony HID-C10 dash devices are failing to work after the recent forced update to 1.7.1604.

Once the device reboots after the installation of the update, all that happens is that the Sony logo appears and the Sony LED below the screen just flashes.

Most people in this situation have been able to get the device into "Special Options" mode, which allows the application of a firmware update over USB.  Unfortunately, a significant number of users have discovered that this update *also* appears to disable the touchscreen for their devices, so they are unable to apply a firmware downgrade to the previous version.

Fortunately, we've found a solution to this issue.  We have a collection of files that can be put on a USB dongle, along with a firmware "", which will force the device to install the update despite the lack of touchscreen response.

You can use this dongle to force the device to install the 1.7.1526 firmware in preparation for using the chumby software when it's released, or reattempt to reapply the 1.7.1604 update if you're interested in using Sony's simple clock.  In the latter case, there is still a strong chance that the device will still not be operational.  We have only tested with restoration of the 1.7.1526 firmware.

(UPDATE: Some users are reporting that reflashing these devices with 1.7.1604 still results in the failing behavior)

Note also that this is *not* official software in any way.  We don't warrant that it will do anything at all, though it's hard to see how anything it could do would be worse than the state of the dash it tries to fix.  If you intend to be mad at me if it doesn't work, then please don't do it.

What this is:

This is a software hack that bypasses the UI in Special Options mode and forces a manual update of firmware from a USB dongle.

What this isn't:

This is *not* the software that enables chumby operation - that software is going through another round of testing before release. 

If you apply the 1.7.1526 update, you will continue to get the forced update alert from Sony.  This hack does not change that behavior. There are a couple of third-party threads on the forum about how to mitigate that if you're interested in taking those steps, but we take no position on them.

This is *not* for any Dash besides the HID-C10 model.

Who this fix is for:

Users that have installed the 1.7.1604 update from Sony, but their device fails to boot completely, displaying only the Sony logo on the display, and a blinking LED, and for which the touchscreen is unresponsive in Special Options Mode

Who this fix is not for:

  • Users who are currently running the 1.7.1526 firmware, having *not* accepted the 1.7.1604 from Sony.

  • Users who *did* install the 1.7.1604 update, and for whom the touchscreen is responsive in Special Options.  Those users can use the normal procedure for installing a firmware update.

What you'll need:

  1. a USB dongle of at least 256MB in capacity formatted as FAT or FAT32

  2. a copy of the 1.7.1526 firmware image at the top level on the USB dongle named as "".  DO NOT UNZIP IT.  We do not host this file on our servers, but a scan of the forum or Reddit at /r/SonyDash should be a quick way to find it. (there is also a post with pointers) The file should be 101776156 bytes in size with an md5sum of 35f49ae0b19aee592189297039cccd9e.

IMPORTANT NOTE: If you're using Windows file explorer, it often hides common extensions, so that "" displays as "update", if you see "" in the file explorer window, right click on it, and select properties, then the detail tab, and make sure the file is actually named "", NOT "".


  1. Download the file ""  from here.

  2. Put that file onto the same USB dongle as the file.

  3. UNZIP THE "" file - you should end up with the following four files at the top level of the dongle, in addition to the two zip files:
    -- flashplayer.cfg (80 bytes, md5 90bb8cefaedc05fdc1dc189ab2475965)
    -- unbrick.swf (6393 bytes, md5 93c2b12dceb94599a0c645ed269b4189)
    -- unbrick_async (104 bytes, md5 232a354d2af0cf883017d080de14b096)
    -- unbrick_sync (59 bytes, md5 0b6c9de9d676368bed314638ef29ea90)

    Your USB dongle should look like this:
    the presence of the file is optional.

  4. Unplug the dash

  5. Insert the USB dongle into the dash's USB socket

  6. Press and hold the MENU/SNOOZE button, while you also...

  7. Plug in the dash.  You must hold the MENU/SNOOZE button for several seconds.

  8. Wait until the dots go by on the screen

  9. The "Special Options" mode UI will appear very briefly, then the USB update will begin.

  10. DO NOT POWER OFF the device while this is happening, or the device may not be recoverable.

  11. When it's complete, it should have successfully updated the device.

What if it doesn't work?

We had a 100% success rate with testers with the following exceptions, easily remedied:

  • People that did not follow the instructions

  • People that did not format their devices as either FAT or FAT32

  • People that used USB dongles that were not recognized by the dash

  • People that installed the wrong firmware or did not name it ""

  • People that did not have the four files or the "" file at the top level of the dongle.

Some "unzip" utilities will put the four files at the same level as the zip file, while others will put them in a directory.  If the latter case is happening to you, you'll need to move the files to the top level.

The dash is *very* picky about USB drives.  It will simply not recognize some brands and models.  In testing, one user found that the dash didn't recognize a USB dongle branded by Sony themselves.  If this process fails for you, that's the most likely cause - find or acquire another dongle.

Many USB dongles have LEDs that blink when they're being accessed.  One clue that such a device is not being recognized is the lack of such blinking.

If the Special Options selection screen appears, but the update does not happen, then it is very likely the USB dongle was not read by the dash, and you need to find another one, or that the files are not in the proper place on the dongle.

What if it works?

If it works, remove the dongle and store it somewhere safe.  The dongle is relatively harmless on its own, but if you were to reboot into Special Options mode, it will force the firmware to install again.  If you remove the four files listed above it will disable that behavior (specifically, the flashplayer.cfg file is the key one that makes this hack work).

Note! All this procedure does is unbrick the device, and roll back the firmware to a working version, it does NOT prevent the Dash from trying to download the bad update again.  We suggest unplugging the Dash for the time being.

We strongly advise you do not accept the update again - all it will do is brick your device again, and you'll have to do this all over.

Your touchscreen should also be working again in Special Options mode.

Thanks to...

  • Chumby user "diamaunt" who was our first victim, and has been invaluable in coordinating the testing of this software

  • Chumbian "Ken", who assisted with investigation that led to this hack.

  • The several folks that allowed us test this software to recover their devices.


It works!  Can you do a hack to disable the cron job that goes out looking for the update?


Woot!   Woot!!!    You are awesome!!    I unbricked my Dash!!    10 min later it asked me to upload the update, I just unplugged it to wait for your next release!!!

4 (edited by joelsef 2017-07-16 05:28:09)


It works like a charm! Thanks guys!

Once you install the UNBRICK and 1526 update it will boot and you can skip the video and then also skip connecting to wifi again if it gives you that option. Then it boots into a simple clock with alarm and a nice message encouraging you to connect the network. DON'T CONNECT TO THE NETWORK! Leave it disconnected for now until Chumby releases the new software. <- photo of the disconnected Sony clock

I tried installing the final 1604 Sony firmware update again, and it bricked the Dash again. So 1526 without wifi it is for now.


Works for me as joelsef saids. Thanks for all your help.


Thank you!!!! This worked for me!! Leaving it disconnected from WiFi for now!



So I have two Dashes that were at the frozen special options touchscreen. This worked great to roll them both back so now at least it boots to a basic clock/alarm.

Well with one of them, I decided to try and experiment with some of the files (psp.tar.gz files). I was trying a bunch of different modifications and installing them to one of my dashes. Well I just kinda screwed one up, lol. I can't even get into special options anymore. My screen just has a Sony logo on it when it boots (it is NOT flashing). If I hold down Menu/snooze it says "Hold 3 seconds for special options" but then returns to the simple Black Sony Logo (no white special options screen is ever shown). Any ideas or did I just brick it myself?


cogop wrote:

Any ideas or did I just brick it myself?

That sounds like a brick.  if you're not getting to a screen where the dots are going across the screen, you're not in any condition where any of our hacks will work.


flyfoam wrote:

Can you do a hack to disable the cron job that goes out looking for the update?

No, since that basically requires modifying and redistributing the Sony firmware image, which we do not have the right to do.


flyfoam wrote:

It works!  Can you do a hack to disable the cron job that goes out looking for the update?

would you rather Duane spend time trying to meddle with Sony firmware and risk a lawsuit from them, or put his efforts on getting the Chumdash patch released?

Cleaning up any loose bits and bytes.


Thank you so much to the people who made this "unbricking of your dash" possible !!

I did it this morning and it worked and so at least I have an alarm clock and not just a blinking sony logo

thanks again

I look forward to the chumby update   You guys rock !!!!!

12 (edited by bradhull 2017-07-16 10:18:38)


Thank you!!!  It took 2 tries (I had all the right files on the thumb drive but I think they were saved in a different order, so I redid everything again and it worked!

I'm using the device as an alarm clock for now with the annoying "You are not connected to the internet" message. 
Thanks to all involved in creating the "unbricking solution.  Like others looking forward to the chumby update.   Is there an ETA on it?

Best Regards,


Hi all.
how can i tell if the Firmware is 1.7.1526 OR 1.7.1604 .the dash is still blinking Sony  :-(
I followed all the instruction to the "T"
is there any one who i could send the Dash to be fixed ? preferably in Canada .
if its within the ethical rules of the site ,can someone call me at 647 529 9276 ?


bradhull wrote:

  Is there an ETA on it?

"When it's ready".

Setting an ETA on things either means they're rushed out to meet the ETA, (like the sony brickification update?) or ETAs are missed when unexpected issues come up.

Or, who knows, things might fall into place early.

All that said, we're hoping "quite soon".

Cleaning up any loose bits and bytes.


jonathan wrote:

Hi all.
how can i tell if the Firmware is 1.7.1526 OR 1.7.1604 .the dash is still blinking Sony  :-(
I followed all the instruction to the "T"

What, *exactly* step by step, did you do?
Did you get to the "special options" screen?
Did it try automatically flashing?
Did you use the right firmware? Download from Reddit, here
Did you try multiple USB sticks?

Cleaning up any loose bits and bytes.


demarks51 wrote:

Is there any harm in just letting the only clock firmware remain until the chumby/dash fix arrives? One dash seems to be working with 1526 but other one seems fine with 1604 as a simple clock. Is there an advantage to keeping it at 1526 until chumby/dash fix? I have a copy of 1526 that I can revert.

I don't think there's any harm leaving it that way, but I didn't go over the changes with a fine-toothed comb to see exactly what they did.  On the other hand, we do know that it's not well tested, or they would have found the bricking issue.


I just registered for this site to say:  THANK YOU!!!!!!  I was ready to toss my 'brick', but your solution worked.  Looking forward to good things in the future, and I really appreciate at least having a clock on my Dash!


I would also like to express my appreciation to Duane and Diamaunt for their great efforts. Not only did they save our Dash units, they have also helped preventing more electronic wastes going to dump fields. THANK YOU!!


Worked great!  I had to go through a couple of usb drives to find one that worked.  SansDisk was the winner.

Thanks again, Duane!  You rule the univere!


mulderjoe wrote:

You rule the univere!

Can't stop the signal...


I tried pressing the Volume+ To cancel update after clicking Ok for update. It just reboots the dash instead of going thru the flash screen and setup again. Faster than USB special options reinstalling again.


deb215 wrote:

touch screen wont let me upload from the usb sad(

Have you tried following the instructions in the first post? you don't need to touch the touch screen.

Cleaning up any loose bits and bytes.


It worked for me. Thanks! Looking forward to future chumby updates...


Thanks for the fix. Worked great.


So far, success. I decided to go ahead on one of them, and connect to a network (I have a few) and immediately put it into night mode. So I still have a clock, with no annoying screen to show me about the update. The other one, I just didnt connect to a network, but just unplugged it until Duane works more magic for us! Thanks for the fix!!!