Topic: Flash is misdetected on

The site, after I login, is complaining I need flash player 8 or later.
I updated that to the very latest version for firefox yesterday, well Tuesday.

Shockwave FlashShockwave Flash 18.0 r0


Re: Flash is misdetected on

After a restart of firefox that issue disappeared. 
I have no idea.