Topic: PyAudio

I've been trying to get pyaudio to work on my chumby hacker board for a bit now. I've noticed that once I get the falconwing toolchain installed and my wifi adapter,  / only has 18 inodes left. Is this normal?

Either way I compiled python and installed it to /mnt/storage because that has enough space/inodes, then I compiled alsa. This didn't seem to be included. I then had to edit the make targets for portaudio to include the libdir of /mnt/storage/lib because it didn't look there (perhaps I missed a configure flag). Once I had this installed, it put libportaudio.a and in /mnt/storage/lib. It looked like I was all set. So I ran python install in PyAudio and it couldn't seem to find portaudio. I edited to include /mnt/storage/lib/libportaudio.a in linkage and the include_dirs to /mnt/storage/include so it could compile against the headers. I was then able to "successfully" install PyAudio. It copied the egg to /mnt/storage, since I still only have 18 files left on /.

Everything looked good and then I loaded python and ran import pyaudio and saw:
Please build and install the PortAudio Python bindings first.

So I edited the python script and removed the try/catch so I could the actual error and saw something along the lines of can't find snd_pcm_open in ../script-packages/ Even though portaudio compiled correctly and it seems like I linked against this okay.

If anyone has any experience with getting pyaudio to work or maybe already compiled binaries (crosses fingers) that would be amazing. I will buy you a bottle of liquor.


Re: PyAudio

I fixed it. What I had to do was recompile alsa, portaudio and pyaudio in that order but also replace /lib/ with the new one I built, also making symlinks for in /lib