Topic: Chumby-OE

After following the examples here … %28Beta%29

24+ hrs later it appears I ended up rebuilding everything which I hadn't planed on but it seems to have worked.
I imaged the file "rom-chumby-falconwing-chumby-starter-image.img" over to a 1gb sd card and tried it in my c1.
It displays the boot screen but the progress bar makes it to about 60% before it seems to lock up.
So, I checked my router for any signs of life and no mac address from the Chumby.
This last attempt I left it alone and 30min later it still hadn't done any more.

Has anyone else tried this yet? Or was this intended for use on the hacker board?

The reason for all this madness is I'm trying to learn how to do all this was originally I was trying to use a usb2serial FTDI adapter with my Chumby one and maybe port mc and serialterm over to run on a Chumby.

I'm also looking into the Debian arm port since I know FTDI devices work with Debian and that I'm liking the apt-get way of installing programs, but I haven't made much progress on that yet.

Re: Chumby-OE

Yup same for me here, it gets stuck after
hwclock: can't open '/dev/misc/rtc': No such file or directory
Sat May 21 00:08:00 UTC 2011
hwclock: can't open '/dev/misc/rtc': No such file or directory

Chumby One board

Re: Chumby-OE

Oh and expected, the image built from the Amazon EC2 image worked fine...

I think I know what it is now... will check when I restart that EC2 instance.

Re: Chumby-OE

Yup just downloaded another image from the EC2 instance and that doesn't work,but that's because I did a git pull on openembedded earlier.

Can anyone tell me what the openembedded git version is on the Chumby EC2 Instance image?

Pretty please...

Re: Chumby-OE

I know Madox has already seen this in another thread, but I'll repost here for anyone else who may be looking for this:

The git hash for openembedded on the vmware image is ba5581f2258fccaf87245f5672c20d3cc43d1849.

(took me 18 hours to download the vmware image to determine those 32 bytes of goodness, so I want it writ large!)

Re: Chumby-OE

This might go better on the Wiki, I've just noticed the default 'chumby-starter-image' does not include the wifi firmware or any of the kernel modules required for Falconwing...

The following is an image recipe for me playing around with Python + Pygame

#Angstrom bootstrap image

IMAGE_PREPROCESS_COMMAND = "create_etc_timestamp"


ZZAPSPLASH = ' ${@base_contains("MACHINE_FEATURES", "screen", "psplash-zap", "",d)}'

DISTRO_SSH_DAEMON ?= "dropbear"
PREFERRED_PROVIDER_virtual/libgl = "mesa-xlib"

DEPENDS = "task-base \
           task-base-extended \
           ${SPLASH} \
           ${ZZAPSPLASH} \
config-util regutil-${CNPLATFORM} \

IMAGE_INSTALL = "task-base \
           task-base-extended \
           rt73-firmware kernel-modules avahi-utils\
           bash vim ${DISTRO_SSH_DAEMON} file \
           python-pyserial \
           python-pyopengl python-pygame python-stringold python-ctypes \
           python-compile python-core python-dev python-distutils \
           python-netclient python-numeric python-numpy python-readline \
           python-shell python-textutils python-threading python-unittest \
           python-pprint python-fcntl libgl libglu \
           networkmanager cnetworkmanager wpa-supplicant python-netclient \
           tslib tslib-calibrate tslib-conf \
       ${SPLASH} \
       ${ZZAPSPLASH} \
config-util regutil-${CNPLATFORM} \


inherit image

Re: Chumby-OE

Remember to run ts_calibrate before scratching head on why touchscreen doesn't work smile

Re: Chumby-OE

The recipe is a BitBake configuration script which OpenEmbedded uses to construct a bootable disk image.  For example if you are using the VMWare image to build, you could save the recipe as meta-chumby/recipes/images/ and build the image with a command like:

bitbake chumby-py

If you are not using the VMWare build, you need to make sure you check out a version of OpenEmbedded which works with the Chumby kernel.  The latest version of OE does NOT build a usable falconwing kernel.   This version issue is, I believe, responsible for the boot-time hang you are seeing.  Use the git hash shown above to get the right version out of git.

Because this is all so fussy, I've created a git repository at which automatically pulls in working versions of OpenEmbedded, BitBake, Kernel Sources, etc.

Re: Chumby-OE

guyc, thanks for creating chumby-oe! It made building images for my 3.5 infocasts much more tolerable. But no good deed goes unpunished, now I have questions. I'm running into the same issue as the OP. Angstrom splash comes up, gets to about 60% then stops. Is there a way to see the console on bootup short of hooking up a ttl cable? I was hoping hitting escape or ctl-alt-f1 might switch to a fb console, but it didn't seem to. And does anyone know if the images created _should_ work on the 3.5? chumby-oe seems targetted at the hackerboard, but I thought(incorrectly it seems) that falconwing was falconwing was falconwing.

Re: Chumby-OE

I would expect it to boot too.  I tried to find some confirmation that it should work.  Here's the best I can find:
In this thread on the support member refers the poster to "Falconwing Software version 1.0.7, build 1.0.3454" which is the same source that forms the basis of the chumby-oe build.  (As an aside, I'm mystified by the poster saying "cross-compiled and booted in < 30 min" given how long the build takes for me!)

Certainly chumby-oe has been used to build images for other non-CHB devices (like the Silvermoon Infocast 8), but I've
only personally worked with the Chumby Hackers Boards.

Since I can't offer much direct help, let me re-state one issue that can cause boot-time hangs, just in case you have taken some shortcut that landed you with a non-standard build environment.  This thread starts with a reference to the wiki instructions that, if followed, would pull in the latest version of the openembedded tools, which are known to generate unbootable images.  The chumby-oe repository pulls in a specific fork of the openembedded tools during the setup process and does not have that problem.

Re: Chumby-OE

In prior iterations I was unable to get the firmware building properly. It seems that may have been due in part to using a 64 bit distro.

For the record, the images in question were built by following the concise instructions provided in the chumby-oe github I installed a 32 bit version of debian in a VirtualBox instance, cloned chumby-oe, ran setup, and let it crunch for a while. There were a couple of annoyances, such as firmware for the wireless card being moved behind a passworded web page, but (again thanks to the README) those were worked out.

So, it looks like I'll solder on a ttl cable and see if there's any indication of what's happening. Is there anything I can do to interrupt the boot sequence though? Or to see the console on screen rather than via serial interface?

Re: Chumby-OE

Sorry - I don't know any alternative ways to view console messages, my only experience is with the CHB.  Hopefully one of the Infocast hackers is listening.