1 (edited by dhockey 2012-01-02 13:25:25)

Topic: github problem

When following directions found here..

I get to the this part...
cd ~
git clone git@github.com:clearwater/chumby-oe.git

which gives the following..

Permission denied (publickey).
fatal: The remote end hung up unexpectedly

Now that I know how to copy the errors- here'e the error for this one...

Cloning into chumby-oe...
The authenticity of host 'github.com (' can't be established.
RSA key fingerprint is 16:27:ac:a5:76:28:2d:36:63:1b:56:4d:eb:df:a6:48.
Are you sure you want to continue connecting (yes/no)? yes
Warning: Permanently added 'github.com,' (RSA) to the list of known hosts.
Permission denied (publickey).
fatal: The remote end hung up unexpectedly

Re: github problem

Authentication is failing, probably because you don't have your local ssh key installed on your github account.  There isn't any compelling reason to go through that setup if you haven't already; you can just clone over http instead if you only need read access.

git clone https://github.com/clearwater/chumby-oe.git

I'll make a point to change the instructions.

Re: github problem

I tried it twice(on debian) but this time I managed to copy the error..

ERROR: The checksums for "/home/dan/chumby-oe/sources/fakeroot_1.15.1.orig.tar.bz2" did not match.
  MD5: expected "248c408b1e06e776c5739871b49bd968", got "88ce306bd1dbab65c5a9df5c60265501"
  SHA256: expected "45fbb9ad611f33224cc09954963dde563cc80fe58c76feb25b6e98550b81729a", got "c43e430ef813bae1c504088a2f66bba436067ef2322940cbc63a77d523c56c12"

NOTE: package fakeroot-native-1.15.1-r0.0: task Fetch failed: ftp://ftp.debian.org/debian/pool/main/f/fakeroot/fakeroot_1.15.1.orig.tar.bz2 checksum mismatch.: Failed
ERROR: Function 'Fetch failed: ftp://ftp.debian.org/debian/pool/main/f/fakeroot/fakeroot_1.15.1.orig.tar.bz2 checksum mismatch.' failed
ERROR: Task 83 (/home/dan/chumby-oe/openembedded/recipes/fakeroot/fakeroot-native_1.15.1.bb, do_fetch) failed with exit code '1'
Waiting for 2 active tasks to finish:
0: libogg-1.1.4-r4.0 do_setscene (pid 22044)
1: eglibc-2.12-r21.8+svnr12323 do_compile (pid 11549)
Waiting for 1 active tasks to finish:
0: eglibc-2.12-r21.8+svnr12323 do_compile (pid 11549)
NOTE: package libogg-1.1.4-r4.0: task do_setscene: Succeeded
NOTE: package eglibc-2.12-r21.8+svnr12323: task do_compile: Succeeded
ERROR: '/home/dan/chumby-oe/openembedded/recipes/fakeroot/fakeroot-native_1.15.1.bb' failed

I got the same error on both tries.

Re: github problem

This problem is being discussed on this thread.  A fix that appears to work has been posted there.