Topic: Flash plugin version 6 or higher required

"Flash plugin version 6 or higher required" is the message I get when I try to run the Toasty Timer widget on three of my Classics. They are all HW: 3.8 SW: 1.7.3 FW 4094.
However, the widget will run without problems on my fourth Classic, which is HW: 3.7 SW 1.7.2 FW: 1830.
Unfortunately, this particular Chumby has some problems holding onto a wifi signal, so I would prefer to use one of the others.
Thus, my question - Is there anything I can do to make the other Classics run this widget?

Re: Flash plugin version 6 or higher required

It looks like the widget doesn't understand the FlashLite 4 player, which is roughly equivalent to the Flash Player plugin version 10, and incorrectly thinks that it's a pre-version-6 plugin.

You could downgrade the firmware from 1.7.3 to 1.7.2 on the other devices.

You can get that firmware here: http://files.chumby.com/resources/class … update.zip

3 (edited by demarks51 2015-12-17 20:24:22)

Re: Flash plugin version 6 or higher required

The only difference in the 3.8 and 3.7 units was the screen as I understand it. Duane may need to interject about software situation. I could only suggest you backtrack to 1.7.2 sw and see if it fixes the problem.

Note: Duane answered while I was writing this.

Re: Flash plugin version 6 or higher required

Here's what I think is going on:

Firmware 1.7.2 has FlashLite 3.1.5, which reports a Flash version of "9,1,120.0"
Firmware 1.7.3 has FlashLite 4.0.2, which reports a Flash version of "10,1,48,3"

My guess is that the widget does string comparison with something beginning with "6", which would fail for the 1.7.3 version.

Re: Flash plugin version 6 or higher required

Thanks for the replies. I didn't understand why the older firmware worked when the newer did not.

Re: Flash plugin version 6 or higher required

Toasty timer may not be friendly to flash 10 or at least spots a conflict. Funny how updates can mess things up sometimes. I have learned the hard way. I am teased for always wanting to update to the newest. New is not always better just newer.

Re: Flash plugin version 6 or higher required

demarks51 wrote:

Toasty timer may not be friendly to flash 10 or at least spots a conflict. Funny how updates can mess things up sometimes. I have learned the hard way. I am teased for always wanting to update to the newest. New is not always better just newer.

My guess is that Toasty Timer was programmed by someone who assumed that  development would stop before version 10, and it just checks that the first number of the Flash version string is greater than or equal to 6.