Topic: Help with GPIO in Non-Beta Chumby Hacker Board

Exactly what it says on the tin; I need help figuring out how to work with the GPIO, for starters the LEDs, on the non-beta Chumby Hacker Board.  I've tried every GPIO-themed thread I can find, as well as a good bit of Google searching, but I can find nothing that will work.  I do everything to the letter, in that I read the directions twice before even attempting, and then I copy/paste into PuTTY to be sure I'm doing everything right, and I can't get it to work.  At all.  This leads me to believe that there was a change from the beta boards (for which the previous threads were written) to the V1.0 sold by Adafruit Industries.

Now, I consider myself, rather electronics-savvy, and I've been trying to do this since I got my v1 board last Christmas.  Having no success, I'm starting to get rather irritated with my own inability to figure this out, and prompt help in any form is greatly appreciated.

Thanks in advance,

Re: Help with GPIO in Non-Beta Chumby Hacker Board

So, solved my own problem, as we all should if we can.  I even took in the spirit of the name of the board, being the Chumby HACKER Board.  What did I do, you ask?  Well, I soldered a single strand of wire (very, very thin) between Q400 (the transistor which is used to switch on ground to the LEDs by way of GPMI_RDY0) and one of the grounds, specifically the one just below the LEDs.  30 seconds later, I have working access to the LEDs on D0-D3, without any of that nasty WTF-filled hassle of dealing with GPMI_RDY0, which never worked for me no matter how many times I read the datasheet or did exactly what I was told by other threads.

Now, time to get back to figuring out how LVDS works so I can hook my Chumby up to a 15" LCD screen I salvaged from a dead laptop...

Re: Help with GPIO in Non-Beta Chumby Hacker Board

I struggled with this for a couple of hours this evening then found the solution.
Working from the schematic it appears that to turn on the LED's on the hacker board you need to turn on the transistor grounding the LEDs and then turn on the relavent LED. I did get stuck with the former as I was wrapped up in the pin name GPMI_RDY0 and faffed for ages trying to set it high thru the registers. I then realised I had been foolish and needed to set the pin it was connected to (bank 0 pin 19) as a GPIO (writing 11 to it thru the MUXSEL1 register, not 00 which incorrectly set it to it's GPMI_RDY0 function). Then when I wrote 1 to the pin and enabled it's output I could get the LEDs to light.
I don't know if it was the same problem you were having.

Re: Help with GPIO in Non-Beta Chumby Hacker Board

I use the following reg_util commands to access the leds. Maybe it helps

GPMI_RDY0 -> leds on
regutil -w HW_PINCTRL_MUXSEL1_SET=0x000000c0
regutil -w HW_PINCTRL_DOE0_SET=0x00080000
regutil -w HW_PINCTRL_DOUT0_SET=0x00080000

regutil -w HW_PINCTRL_MUXSEL0_SET=0x00000003     PIN0  -> GPIO
regutil -w HW_PINCTRL_DOE0_SET=0x00000001        PIN0  -> output
regutil -w HW_PINCTRL_DRIVE0_SET=0x3            PIN0  -> 12 mA
regutil -w HW_PINCTRL_DOUT0_SET=0x00000001        PIN0  -> high
regutil -w HW_PINCTRL_DOUT0_CLR=0x00000001        PIN0  -> low
regutil -w HW_PINCTRL_DOUT0_TOG=0x00000001        PIN0  -> toggle