Topic: FW 20 problems

Firmware 20 just got pushed out and I can't seem to connect to anything on the internet.  SSH is still working but little else is.


Re: FW 20 problems

Anyone else having a problem with FW 20.  Tried holding down the reset button for 4 seconds.

the little icon in the corner stays on connecting....

I can't load other web pages through NeTVBrowser

I'm able to enable SSH (I have to press the reset button once) and log in, however the menu on the screen does not go away.

I can ping outside services to DNS seems to be working.

a little nervous that if it can't get to the outside world, how is this going to get fixed,  yikes.

Re: FW 20 problems

When I attempt to use the NeTVBrowser command it responds that it failed to send the arguments.

Re: FW 20 problems

Does SetUrl command even work for you?
from SSH terminal:
NeTVBrowser SetUrl

Can you or can you not ping IP address outside?

Re: FW 20 problems

I worked things out with bunnie.

seems like the syntax for the NeTVBrowser command may have changed.  We came up with a work around for now.

6 (edited by torinnguyen 2011-10-27 20:05:43)

Re: FW 20 problems

There is indeed a bug with sending arguments through command line in the new firmware.

A clean way to do SetUrl at the beginning of the browser is to modify /etc/init.d/chumby-netvbrowser script.
change this line
NeTVBrowser -qws -nomouse > /dev/null 2>&1 &
NeTVBrowser -qws -nomouse SetUrl > /dev/null 2>&1 &

Note that the new NeTVBrowser has a keep-alive timer enabled.
You should implement a JavaScript function "fCheckAlive();" to return 'true' in order to keep the timer happy.
It is documented here … #KeepAlive

Alternatively, you may choose to disable the timer.
Since command line arguments are not working, you have to use HTTP API to turn it off.
Anywhere in your page, issue a call to http://localhost/bridge?cmd=keepalive&value=off

It is recommended to go through HTTP API as much as possible. Command line interface was meant for quick testing.