1 (edited by kasi 2009-06-30 00:09:30)

Topic: bend switch not working


the support said it would be a good idea to post my question here in the forum as well.

My chumby was dead and I successfully resurrected it by replacing the two 3.3V regulators (see topic http://forum.chumby.com/viewtopic.php?id=3137 ).

Now everything works again except the bend switch. The switch itself is working but the voltage signal at the concerning cpu-input constantly gives 0.13V no matter if the switch is pressed or not. If i understand it correctly there should be 3.3V if not pressed and ground when pressed. So the problem is that I have a little resistance to ground at that input which I measured to be 30 Ohms. I can't tell where this comes from. It's still there even if I disconnect the chumbilical cable. In the circuit at this cpu-input there's then only a capacitor (which is not the problem, i desoldered it and checked it to be ok, same behavior) and a resistance R712 to the P33V (measured to be 3.27V).

So I have two questions:

1: Where does this little resistance to mass come from? Can the CPU-bend-input be broken or repaired?

And as a workaround:

2: how can i disable this input in the kernel? I tried "rmmod chumby_sense1" but this leads to an immediate reeboot of the control pannel. I want to get into the control panel by tapping the upper left corner of the touchscreen but it always gets back to the widgets because of the signal at the cpu-bend-input.
I also tried "cat /dev/switch > /dev/null" which works when I make the input via ssh. But the problem is that it hangs after this input. I can work with the chumby then, but I want it to load when starting the device, and when putting this line into a debugchumby file it hangs there and doesn't boot.

Wow, hope I made the problem clear and that somebody can help me, either with a hardware tip or a linux kernel/boot solution.

Many Greetings

Re: bend switch not working

Part of the problem is that the watchdog timer lives in chumby_sense1 as well, so if you remove it, the WDT will consider the board frozen and automatically reboot it.

As a workaround, you can modify your debugchumby script to e.g. "rm /dev/switch", then either "mknod /dev/switch c 1 3" or "cp /dev/null /dev/switch", to make /dev/switch be a copy of /dev/null.

3 (edited by kasi 2009-07-02 06:20:56)

Re: bend switch not working

Thank you very much, I'll try the workaround when I'm back from work.

EDIT: yeah that's a solution i can live with. hope that not so many widgets depend on a full size "touchability" wink