Topic: WinSCP and Chumby 8

Today I tried to use WinSCP to load some files on to a Chumby 8. This is a relatively new (to me) C8 that I purchased from someone else. I am fairly familiar with WinSCP and have had no trouble using it with a variety of other Chumbys, including a Chumby 3.5, Chumby One, Infocast 3.5 and Infocast 8, all of which I was able to successfully connect to with WinSCP today. But not the C8. This is my only C8.

When I looked in the log file, this is what I saw that seems to be related to the refusal to connect:

. 2016-12-25 17:02:07.763 Host key matches cached key
. 2016-12-25 17:02:07.764 Initialised AES-256 SDCTR client->server encryption
. 2016-12-25 17:02:07.764 Initialised HMAC-SHA1 client->server MAC algorithm
. 2016-12-25 17:02:07.764 Initialised AES-256 SDCTR server->client encryption
. 2016-12-25 17:02:07.764 Initialised HMAC-SHA1 server->client MAC algorithm
! 2016-12-25 17:02:07.777 Using username "root".
. 2016-12-25 17:02:07.895 Access granted
. 2016-12-25 17:02:07.895 Opening session as main channel
. 2016-12-25 17:02:07.901 Opened main channel
. 2016-12-25 17:02:07.949 Primary command failed; attempting fallback
. 2016-12-25 17:02:07.980 Started a shell/command
. 2016-12-25 17:02:07.980 Server sent command exit status 2
. 2016-12-25 17:02:08.018 --------------------------------------------------------------------------
. 2016-12-25 17:02:08.018 Using SFTP protocol.
. 2016-12-25 17:02:08.018 Doing startup conversation with host.
! 2016-12-25 17:02:08.018 ash: exec: line 3: sftp-server: not found
. 2016-12-25 17:02:08.019 Disconnected: All channels closed
* 2016-12-25 17:02:08.161 (EFatal) 

I am hoping someone who has a greater understanding of Linux than me can point me in the right direction so that I can get this fixed.


Re: WinSCP and Chumby 8

can you ssh in?

Cleaning up any loose bits and bytes.

Re: WinSCP and Chumby 8

Is sshd enabled on the device?

Re: WinSCP and Chumby 8

Yes, SSHD is enabled. I enabled SSHD by clicking on the button on the Device Info screen, the way I would on the other Chumby versions. I can use PuTTY to get into the system, but, I just don't know enough about PuTTY to use it to copy files to the right place.

Re: WinSCP and Chumby 8

The problem is displayed with this line:

! 2016-12-25 17:02:08.018 ash: exec: line 3: sftp-server: not found

Your client is attempting to do an SFTP session, and the chumby doesn't support that.  The sshd_config file says

Subsystem        sftp        /usr/sbin/sftp-server

but this file doesn't exist on the machine and so sftp attempts will fail.

You should configure the client to use SCP and not SFTP.

Re: WinSCP and Chumby 8

Yes, that's correct, sftp is not supported on the C8 - as far as I know, the older chumby don't support it either, so I don't know why you're having a difficulty with just the C8.  The I8 runs a very similar middleware stack as the C8.

SCP seems to work fine to a C8 using the command line, so see if there's some configuration in WinSCP to make it use the SCP protocol instead of SFTP.  I'm not a Windows user, so I'm afraid I can't be of much help.

Re: WinSCP and Chumby 8

Thanks sweh and Duane. I will have to get back to experimenting later. We were (supposedly) upgraded to a fiber Internet connection yesterday after about 5 1/2 hours of work. The connection lasted  from 7:15 PM to 10:45 PM, when we got a Gateway Authentication error. After our provider ran a bunch of tests, they concluded a technician needs to come out today between 4 PM and 8 PM. So Chumby testing is on hold.

But I thought I had tried the various connection options to the C8, and all seemed to fail. And I did carefully note the options on my other Chumby variations, and all have been using SFTP.

I will update this with more definitive results once I have my Internet properly working.

Re: WinSCP and Chumby 8

I was able to connect to my C8 using SCP. I also tried using SCP to connect to the other Chumby versions, and that seems to work. But when it comes to SFTP, all of the versions all connect fine using that, except for the C8. Strange. But, at least I now have a solution. Thanks for your help with this.