Topic: FHEM on Chumby One

Hey folks,
has anyone ever tried to run FHEM (perl server for house automation) on a chumby device? I'm not really into linux yet and I'm pretty sure I'm a bit naive ;-) but I've seen perl is already included on my chumby so I tried to copy the fhem-5.2.tar.gz to /mnt/storage and unpacked it with tar -xzvf followed by a make install-pgm2. Unfortunately it does not work out of the box. When trying to start the server with perl /usr/bin/ I run into the following error:

chumby:/# perl /usr/bin/
Can't locate in @INC (@INC contains: /usr/lib/perl5/5.10.0/arm-linux /usr/lib/perl5/5.10.0 /usr/lib/perl5/site_perl/5.10.0/arm-linux /usr/lib/perl5/site_perl/5.10.0 /usr/lib/perl5/site_perl .) at /usr/bin/ line 33.
BEGIN failed--compilation aborted at /usr/bin/ line 33.

Line 33 in the script is somewhere around:

use strict;   <-- line 33
use warnings;
use IO::Socket;
use Time::HiRes qw(gettimeofday);

Is there any way to get it running?
Do I need to go through the Scratchbox stuff and compile a new perl?  :-(

Re: FHEM on Chumby One

Well, the Perl that comes on the chumby is really a "miniperl", which is sufficient to write simple scripts for which bash is a PITA.

What you need is a more complete Perl with a bunch of standard modules - it's fairly straight forward to build with Scratchbox.

Re: FHEM on Chumby One

I tried it yesterday with the help of the Wiki Page for setting up Scratchbox but failed at the package:


Which seems not to be part of the stable release.