Topic: Excessive wireless errors on Chumby8

Happy holidays, chumbians. I'm a multi-chumby-owner, the most recent being my shiny preordered red Chumby8. I've struggled with wifi issues off and on, but I have been waiting to see what effect the latest software rollout had on the behavior. I'm posting because I am still seeing problems. They manifest themselves as various apps hanging, particularly image loading apps such as ImageURL. I have a ChumbyOne literally 4 feet from this one. It does not exhibit any network errors and can run without hanging for weeks on end. The Chumby8 seems to only have enough stability to run for 24hr or so until either I need to manually exit and restart the widget or sometimes power cycle the whole chumby.

Here are what the network stats look like:

Wireless Stats

wlan0     MRVL-SD8686  ESSID:"pets"  Nickname:""
          Mode:Managed  Frequency:2.437 GHz  Access Point: 00:13:10:F9:00:49   
          Bit Rate:54 Mb/s   Tx-Power=13 dBm   
          Retry limit:9   RTS thr=2347 B   Fragment thr=2346 B   
          Power Management:off
          Link Quality:64/100  Signal level:-68 dBm  Noise level:-95 dBm
          Rx invalid nwid:0  Rx invalid crypt:0  Rx invalid frag:2825324
          Tx excessive retries:317141  Invalid misc:1141244   Missed beacon:0

Inter-| sta-|   Quality        |   Discarded packets               | Missed | WE
face | tus | link level noise |  nwid  crypt   frag  retry   misc | beacon | 22
wlan0: 0001   64   188   161        0      0 2825324 317141 1141244        0

I have tried moving my wireless networks to all three of the major channels (1,6,11) with the same effect. I have tried the Chumby8 near and far from the access point. No matter what I do, I see regularly climbing errors such as the excessive retries, invalid frag, invalid misc, etc.  These stats on my chumbyOne are all zero. Based on my experience with other wireless linux systems, I'd expect 0 readings optimally unless there was something particularly freaky going on (high strength signal collisions for example)

Was this a behavior that was expected to be addressed in the latest major OS update? Is this issue a known bug that is being worked on? Are there any workarounds that I can perform that can increase the performance and stability of my chumby?

I really like the device(s) but these persistent issues have gotten in the way of me doing anything more sophisticated with them (whole house automation) or recommending them to family and friends. If someone can help me figure this out, I will be a good advocate for the chumby devices and software.

My background is in sysadmin/*nix, so feel free to have me run some experiments if that would be helpful.