Topic: Streaming internet radio station stops intermittently.

I am trying to play an internet radio station through the My streams by providing the url and am seeing the following issues:

it will keep stuttering from time to time;
it will stop playing after some time, with the status showing "Idle", and I have to hit Play again. This is all with the Chumby within a few feet of the wireless access point.

How can I try troubleshoot this further.

I tried running btplay in the ssh shell using the debug option to see if I got any debugging info, but I couldnt tell if it was reallt playing it or not because I didnt hear anything from the chumby. Below is the output of what I tried doing.

chumby:~# btplay --debug
btplay client v1.
BLTP_ParseCommandLine: args[0]=
Connected to btplayd instance 1677
main(): preprocessing args
main(): front-end processing 1 input args
main(): processing argList[0]=
fgets_timeout() returning 13: OK 100 reset

Got response: OK 100 reset
Matched request 100
fgets_timeout() returning 17: OK 101 playnow 0

Got response: OK 101 playnow 0
Matched request 101
playnow *

Re: Streaming internet radio station stops intermittently.

So after browsing some more threads, I am looking at the command file:

chumby:~# cat /tmp/.btplay-cmdin

and I see a lot of:

[3697] play * … DIALUPCMP3
[3698] play * … DIALUPCMP3
[3699] stop
[3700] play *
[3701] stop

Where is the stop command coming from? I am sure this corresponds to everytime my stream stops playing. This also applies to Pandora which is the other stream I have tried.

Re: Streaming internet radio station stops intermittently.

So I turned off all apps, and now these issues have almost gone away. Previously I had the Local Info app, the Stock Quotes, Facebook apps running.