Re: YouStreams-Widget

spunk_ wrote:


and the same question here like for searchtube:

what happend with youstreams?
it is still working fine on my chumby but i cannot find it anymore here on the page.

Please see: http://forum.chumby.com/viewtopic.php?pid=32533#p32533

The developer has made this app private to update it. It should be back up soon

Re: YouStreams-Widget

Nonsense, CWard !

I made YouStreams private because there is a severe bug in Chumby's latest Controlpanel-Update 2.8.72.

I will make it public again, when you release 2.8.73, which I had the "honour" to test last Friday (Duane sent me an email with 2.8.73 attached, I confirmed, that it fixes the wrong chumby-id bug in 2.8.72).


Re: YouStreams-Widget

Ratfatz is correct - the bug s in the Control Panel. I will be deploying it shortly, and Ratfatz should be able to reenable that widget.

Re: YouStreams-Widget

how is it going?
any news when 2.8.73 will be online?

thanx for your support smile


Re: YouStreams-Widget

I gave it to QA a few days ago - it's in their hands.

Re: YouStreams-Widget

Very nice widget.We all look forward to the new version.Good job!!Keep going.

Re: YouStreams-Widget

Any word on this app. for the Insignia Infocast

Re: YouStreams-Widget

Fantastic widget! Working well - keep the updates coming

Re: YouStreams-Widget

Is there any timeline as to when this will be functioning on the Insignia Infocast?

Re: YouStreams-Widget

I tried to install Youstreams on my new Infocast 8", I can see the icon in featured channel - but when I open the channel, I don't see this application - is it the control panel bug or I'm doing something wrong. I can see this app inside the channel on my online account. What is the "YouStreams ID" (online account) - what should I put to this edit box? Some sort of ID which I should get on Infocast after proper installation of YouStreams?

136 (edited by Ratzfatz 2010-12-30 15:45:11)

Re: YouStreams-Widget

Unfortunately YouStreams does Not work on the Infocast because httpd does not run on the Infocast (on startup). I have to write this again and again (http://forum.chumby.com/viewtopic.php?pid=30296#p30296 http://forum.chumby.com/viewtopic.php?pid=30587#p30587) because there's no way for me to prevent the app from re-appearing on insignia.chumby.com. It's hopeless.

Re: YouStreams-Widget

Thanks for very fast respond. Happy New Year!


Re: YouStreams-Widget

What complicates this is that there are now *two* different Infocast devices, one of which is capable of running YouStreams (the 3.5") and one which isn't (the 8").  The Insignia 3.5" does have httpd running and appears to widgets to be very similar to the Chumby One.

When you add widgets to a channel, it has no way of knowing which devices you will be playing it on, since a channel can play on no devices, one device, or multiple different devices - at the moment, the widget is delivered to the 3.5" devices, and not to the 8".

When the Infocast 3.5" was introduced, all widgets that were marked as compatible with the Chumby One were promoted to be compatible with the Infocast 3.5", except for a couple that had contractual restrictions.  That meant that this widget was made available on the Insiginia variant of the site.

However, since it appears that Ratzfatz would prefer that the widget not appear on insignia.chumby.com at all, I've removed it from that site.  I can also remove it from all Infocast branded devices if Ratzfatz would like that to happen.

Re: YouStreams-Widget

Hello all,

I understand the doubt of Ratzfatz and Duane. However due to the lack of MyStream-Application on my Infocast 8'' I was looking for a way to get this widget running on it anyway.

For those of you, which want to get it running in an unofficial way, here how to get it managed:

Unfortunatelly YouStreams seems to be marked to be usable only on devices with little screen resolutions, such Chumby One.

The work around may be:

1. You have to download the swf-File of YouStreams widget and upload it (marked as private) as your own application (submit an app). You should leave the Display Size choose box on "Any". After that you can choose your Widget and it will be displayed on the Infocast. Please respect Ratzfatz and don't upload it as an public application!

2. Follow the instruction instructions of the widget (i.e. download the debugconf file to an usb stick, reboot your Infocast).

3. After reboot there is still an issue, because the widget does not display any version number. This is because the httpd is not starting by default on your Infocast. You can fix it by the following steps:

3.1 Activate SSH (touch the INSIGNIA text on top left, touch the "Pi"-Symbol, touch "SSHD".

3.2 SSH-Login onto your device: ssh root@IP - the IP is also shown in the Dialog in step 3.1.

3.3 In the SSH terminal type:

echo "/usr/sbin/httpd -h /www" > /psp/userhook1
chmod 755 /psp/userhook1

3.4 After restart activate SSH again, login again and check whether httpd is running or not:

ps awx|grep http

You should see something like:

780  root       0:01 /usr/sbin/httpd -h /www
890 root       0:00 mDNSPublish chumby-18-25-8d _http._tcp 80

The first numbers (process ids) may differ, but it is necessary, that the httpd is present!

4. Now you can fulfill the registration of YouStreams.

@Ratzfatz: Maybe a hint: If your debugconfig script would create the userhook1 for Insignia users, then your widget will be fully usable. Could you please think of integrating it? I understand your frustration with Insignia, but the Insignia users are frustrated too because of lack of such needed features such multiple alarms and the MyStream application. Therefor the YouStream app will be the only alternative on Insignia Infocast 8'' to hear another webradio than this from Shoutcast.

Many thanks for your widget!

Re: YouStreams-Widget

Awesome, awesome widget, Ratzfatz!  I have both a Dash and a C1.... YouStreams availability on the C1 has made it my preferred device (it really sux that Sony doesn't support your widget).

And this thread is great, too!  Nearly every question I had about YouStreams was answered, even discussed in detail.  I actually just have two remaining:

As I understand it, non-working radio streams can cause performance problems (the Chumby's CPU cycles get wasted on non-functional tasks), so I have deleted them from my list.  But should non-working podcast RSS feeds also be removed?  (I have a bunch of podcast RSS feeds entered that aren't working and haven't had the time to figure out how to fix them.)

Secondly, I wonder if there is a way for YouStreams to 'scrape' all of the podcasts on a webpage -- e.g. http://www.npr.org/templates/rundowns/r … hp?prgId=3 -- and dump them all into a single category?  National Public Radio unfortunately does not provide a podcast RSS for their popular "Morning Edition" and "All Things Considered" programs; instead, each story has it's own podcast RSS, and the stories change every day.

Again, thanks for a terrific widget!  Makes the C1 definitely worth getting!!!

Re: YouStreams-Widget

You  Streams on the Chumby8?

142 (edited by gsharpe 2011-04-26 11:27:47)

Re: YouStreams-Widget

   I have an Insignia Infocast 8 and went through duke4d's workaround, but had to change the
procedure somewhat to get it to work for me.  I'm sure there was an easier way, but I'm
new at this, so I got the YouStreams file by looking at the source to the YouStreams
page:  http://www.chumby.com/guide/widget/YouStreams.  In the source, I found the URL
used to get the YouStreams file: 

http://s3movies.chumby.com/cdn/xmlmovie … 1E681DF646

I was then able to download the file by pasting the URL into the browser and just renamed
it youstreams.swf.  I used that to upload as a private file in my account, but had to
change the name of it to something other than YouStreams (even though it was a private
file, it still saw it as a conflict with the public YouStreams file).  I named mine
YouStreamsTest.  I had previously added the public YouStreams widget to my channel even
though it would not load to my Infocast 8, so I used it's image to capture an icon to use
in creating the private file. 

While still on the YouStreams page, I clicked the help button to get a YouStreams-ID.  I
then used that to enter at http://youstreams.appspot.com where I then downloaded the
debugchumby script.  As instructed, I inserted it into a USB port and booted the Infocast

Once I had run the script on boot and added the private widget to my audio channel, I
activated SSH through the pi menu and then logged into the machine using Putty.  I tried
the commands as written, but when I rebooted, httpd did not appear in the process list. 
After reading the chumby wiki, I moved userhook1 to a directory I had to create under
psp called rfs1, so it appeared as /psp/rfs1/userhook1.   After rebooting, it appeared in
the process list.

At that point I could bring up YouStreams and hit the help button to get another
YouStreams-ID which I used to then configure the stations and podcasts.  It was
interesting to see that the appspot site recognized the script had been run on my
Infocast 8 and did not offer the debugchumby script for download.

Hopefuly this will help anyone who is as new to this as I am.  I learned quite a bit from
stepping through duke4d's workaround and Ratzfatz's awesome widget, YouStreams,
is working great on the Infocast 8!


143 (edited by duke4d 2011-04-26 12:36:18)

Re: YouStreams-Widget

@gsharpe: Many thanks for helping improve the user experience by fixing a bug in my workaround.

Currently I am experimenting with improving Infocast 8'' by using the control panel of my little chumby one on it. This has several advantages over the control panel used in Infocast:

* Your Stream application is working (you can define the URL of your favorite web radio stream)
* Possibility to get the wake up alarms working with your web radio streams

As I am using my chumby exactly this way (for waking me up with my favorite web radio stream), it was very important to get this features working. However, there are some disadvantages:

* My current work allows only the control of brightness in three steps: off, dimmed, full. This is because the control panel recognizes the hardware not correctly and allows only this three steps.
* A little delay between start the widget and when it appears.

And here how it works:

* Download the current firmware upgrade file for chumby one from here, extract it. Locate the file rfs.tar.gz and extract it too. Inside of extracted directories find the controlpanel.swf (rfs/usr/widget/).
* Place this controlpanel.swf onto your usb pen drive into the directory alt_cp:

cd /mnt/usb <-- or where your usb pen drive is mounted on
mkdir alt_cp
cp /home/.../controlpanel.swf alt_cp/

* Place this script onto your usb pen drive:



/bin/sleep 2

cd /mnt/usb/alt_cp

* Place this perl script onto your usb pen drive into the directory alt_cp:



$path = "/mnt/usb/alt_cp";
$s1_stim = "WidgetPlayer.loadWidgetIntoProxy";
$s2_stim = "ScreenManager.widgetPlayerMode";
$d2_stim = "ScreenManager.setDim..: 2";
$d1_stim = "ScreenManager.setDim..: 1";
$d0_stim = "ScreenManager.setDim..: 0";

open (PRG, "$path/start_player.sh |");
while (<PRG>)
  $line = $_;
  print "LINE: $line\n";
  if ($line =~ /$s1_stim/)
    print "\n\n  Stimmulus s1 found!!!\n\n";
    `$path/switch_fb_delayed.sh &`;
  elsif ($line =~ /$s2_stim/)
    print "\n\n  Stimmulus s2 found!!!\n\n";
    `$path/switch_fb_delayed.sh &`;
  elsif ($line =~ /$d2_stim/)
    print "\n\n  Stimmulus d2 found!!!\n\n";
    open (DIM, ">/sys/devices/platform/silvermoon-bl/backlight/silvermoon-bl/brightness");
    print DIM "0\n" ;
    close DIM;
  elsif ($line =~ /$d1_stim/)
    print "\n\n  Stimmulus d1 found!!!\n\n";
    open (DIM, ">/sys/devices/platform/silvermoon-bl/backlight/silvermoon-bl/brightness");
    print DIM "10\n" ;
    close DIM;
  elsif ($line =~ /$d0_stim/)
    print "\n\n  Stimmulus d0 found!!!\n\n";
    open (DIM, ">/sys/devices/platform/silvermoon-bl/backlight/silvermoon-bl/brightness");
    print DIM "100\n" ;
    close DIM;

* Place the following to scripts also into the alt_cp directory too:



/usr/bin/chumbyflashplayer.x -u 0 -i /mnt/usb/alt_cp/controlpanel.swf -Q -f 2  2>&1



/bin/sleep 2;
/usr/chumby/scripts/switch_fb.sh 0

Connect the usb pen drive into the Infocast 8'' and boot Infocast. After a while the well known blue controlpanel appears.

Have fun!

Re: YouStreams-Widget

I can only add to this.  On Duane's guidance I replaced my Insignia Infocast 8 with a Chumby 8.  The C8 is a better device all the way around but still has a few problems: 

     Some of the music sources aren't available for alarm/tasks use
     Some of the radio stations I want are not on any of the sources

YouStreams seemed like a possible solution but it doesn't appear in my channel when it is assigned on the website and I keep getting the "script download" notification.  it won't register.

I tried going throug here but very little seems to be pointed at the C8.

Is there a solution for this?


Re: YouStreams-Widget

I followed the instruction, but the App doesn't work.

Some tricks?



146 (edited by slewis7 2012-01-04 11:16:36)

Re: YouStreams-Widget

Hi!  Insignia 8 owner here running the latest C8 firmware which restored the sleep timer!  Right now I use MediaFly to play my streamed podcasts, but I understand that MediaFly is switching over to serving the enterprise industry only and presume the Chumby MediaFly support will be dead soon.  Then I will be without a streaming solution for my Chumby and podcasts.  Of course, like many I discovered YouStreams and then that it is not supported on the I8.  I see here there may be some work arounds, thanks to the efforts of some very smart community members.  Is this my best option to try or is there a future streaming solution for I8 hardware running C8 firmware?

Thanks in advance for reading and responding!

Re: YouStreams-Widget

Is it possible to use national symbols?

Re: YouStreams-Widget

Youstreams cannot contact server

I notice some threads about the youstreams app.
I had never used it so I tried it. I installed it on one of my channels from chumby.com

It seems like it was probably working a couple of months ago.
Today it says "unable to contact server" when I push the help button to get the ID to configure.

I have the
on the computer, and the box for entry of the chumby ID is there, but the app on the Infocast 3.4 cannot contact the server or display it's ID.

This app seems down.
In reading some of the threads here a USB stick with DebugChumby on it is required. I haven't tried that.

The server is working but the chumby cannot contact the server, or it says it can't.
It's no big deal, I was just pointing out the errata.

Re: YouStreams-Widget

Duane was working on moving youstreams to primary music sources. It seems to be in the todo list. It is not a working widget now.

Owner of 3 Sony Dash, 2 Info 8.

Re: YouStreams-Widget

Is there any progress on reviving youstream into media sources? Last I remember that was already in the mix and only needed some finishing touches.

Owner of 3 Sony Dash, 2 Info 8.