Topic: Resurrecting a Chumby Classic


I have an original Chumby classic (black leather) which I hoped to resurrect from storage as an NTP accurate clock.  When I tried to connect to WiFi it takes a long time and eventually returns " is unreachable".

I tried to use the firmware linked in the pinned thread here, but the Chumby does not seem to recognise it as a valid upgrade (properly FAT formatted USB stick).  I only have the option "Cancel" as the "install from USB flash drive" option is grayed out.

It says "current firmware version : 1830" which I imagine is ancient as it doesn't even match the version string use more recently.

Where should I begin to diagnose this please?
I don't have a serial console connected.

Re: Resurrecting a Chumby Classic

What is the capacity of the USB stick?  Chumby devices require something less than 4GB.

The "1830" you're seeing is actually a build number, not a firmware version.  It's actually not that old, probably version 1.7.2, while the current is 1.7.3.  Any differences would not affect Wifi or the ability to upgrade.