Topic: fb_cgi.sh not working on Dashes?

Hi,

I am so amazed at all the possibilities the Chumby world has opened for the Dash users.
Of course I also want to see the display of the device on the bedside table when I am at work.
On the chumby wiki page I found that this should work when I have the httpd daemon running and turn on screen capture with the /usr/chumby/scripts/fb_cgi.sh script. I should then be able to see my devices screen as a jpeg captured via the url http://<my dashes ip>/cgi-bin/custom/fb0 and fb1.
Well, I see SOMETHING when I do that, but it doesn't look like the display of my Dash.
It looks more like some random memory turned into a graphic.

Rgds,

Alaric11

2 (edited by drexful 2017-08-11 04:38:47)

Re: fb_cgi.sh not working on Dashes?

I think you need to add the cgi script to /www/cgi-bin or  /psp/cgi-bin.  Is there a script on the folder?

Owner of a Chumby One, Insignia 3.5, and Sony Dash C10. A tinkerer at heart and IT manager by trade.

Re: fb_cgi.sh not working on Dashes?

No, that's not it. The script itself works fine. It creates the necessary links in the cgi-bin directory.
It's just that the imgtool is producing a picture of some random memory and not the screen contents.

Alaric11

Re: fb_cgi.sh not working on Dashes?

"imgtool"'s capture mode was designed for the other chumby devices, they don't work properly on the dash, which manages the display differently.

Re: fb_cgi.sh not working on Dashes?

I was afraid this would be the case.
Any plans to add support for the Dash into imgtool? It's VERY handy to be able to check the devices display over the net.

Re: fb_cgi.sh not working on Dashes?

Unfortunately, it looks like we don't have independent read access to the frame buffer.

Re: fb_cgi.sh not working on Dashes?

Can this be of use, Alaric11?  http://products.sel.sony.com/opensource … 1.0.tar.gz

Owner of a Chumby One, Insignia 3.5, and Sony Dash C10. A tinkerer at heart and IT manager by trade.