1 (edited by mod 2013-12-06 06:04:10)

Topic: SHOUTcast radio search function b0rken?

One of the picks in the Music menu (in addition to items like BlueOcty and iheartradio) is SHOUTcast radio and although it seems I can still select it and "Go To" it, the only selections available anymore are those presented when no search is active and the status bar shows a message like "Loading popular stations" which seem mostly to be dainbramaged crap.  If I specifiy *anything* using the search tool it always comes back with a blank page showing zero results.  Seems like this has been true for at least a week now - anybody else?  I can still listen to various streams using the other facilities and I can listen to the picks presented when no search is active, so it seems like a lot of the plumbing is OK on my end.

2 (edited by mod 2013-12-06 06:22:02)

Re: SHOUTcast radio search function b0rken?

I should add that SHOUTcast's search function works fine on their WWW site if I visit it using my desktop machine (shoutcast.com).  Further, if instead of choosing the "SHOUTcast Radio" pick in Chumby's Music menu I choose "My Streams" and (tediously, laboriously) create an entry and key in the resultant playlist URL reported by the SHOUTcast search on my desktop machine, Chumby will play that stream just fine.

Re: SHOUTcast radio search function b0rken?

I'll look into it, but as you may have heard from the news, AOL has been planning on shutting down SHOUTcast entirely.  Allegedly they are in negotiations to sell it, and WinAMP, to Microsoft, but there isn't been any news about that lately.

It's possible that certain functions are being shut down, and we may lose it all at some point soon.

The search function on the device uses a web services API that uses an API key, so it's different than the search on the main site.  AOL may have disabled it.

Re: SHOUTcast radio search function b0rken?

Ah.  Dang...  yes, I had heard something about WinAmp's demise but didn't give it much thought as I don't use it and didn't comprehend the AOL/SHoutcast connection or its effect on the already diminished capabilities of our poor little Chumbys.  Oh, well, as long as there are streams out there that I want to play I guess I'll have to get by keying their URLs in by hand...

...unless (hoping!) somebody knows how to poke a playlist URL directly in via SSH - anybody?

Re: SHOUTcast radio search function b0rken?

OK, I looked into it - all SHOUTcast web services API calls are returning a "missing parameter" error, however, the calls themselves match the documentation supplied by them.

The Chumby servers cache certain results, which is why you're getting the generic list on load.

There's a thread on their forum discussing the issue.  Allegedly this is fixed, but I have not been able to confirm.

6 (edited by mod 2013-12-06 09:08:05)

Re: SHOUTcast radio search function b0rken?

I confirm that it appears to be working again at the moment.

Thanks for looking into this.

Re: SHOUTcast radio search function b0rken?

Yeah, it just came back about five minutes ago.

There's still an open question about what happens later this month.  Let's all hope for the best.

8 (edited by mod 2013-12-06 09:35:42)

Re: SHOUTcast radio search function b0rken?

> ..unless (hoping!) somebody knows how to poke a playlist URL directly in via SSH - anybody?

It looks like I can use scp to pull a copy of /psp/url_streams over to my desktop machine where I can modify it (I have so far only tried reording the list) and then push it back where the changes appear to be persistent and show up as expected in My Streams.  Not sure if I can generate new entries by hand as it appears they contain hashes or something along those line...

Re: SHOUTcast radio search function b0rken?

You can generate your own hashes - they just need to be unique.  They were originally done to implement a device-to-device sync function that was never completed.

Re: SHOUTcast radio search function b0rken?

We were away over the holidays and returned to see our Chumby was no longer connected to the internet. My Chumby is the one with the soft tan case and has model number of CCH7C05710.  When i try to connect to my home WiFi, I continue to get an error message that reads "failed to obtain IP address. Chumby.com is unreachable." I get this when using the existing connection and also when i try to establish a new connection. My home WiFi has a WEP key and it has always worked. When i scan for devices, the Chumby recognizes the WiFI and other devices in the area. It simply will not allow me to connect.

I am getting a MAC address as follows: 00:12:0E:92:96:CE

If you have any ideas, that would help, that would be great! Thanks, Kevin


Re: SHOUTcast radio search function b0rken?

I'm just a civilian but as of the time I created this thread (approx 1 month ago) I've had no substantial problems with my Chumby, the aforementioned "reduced capacities" being factored in.  As of approx 7am EST my Chumby was OK and playing SHOUTcast and such.  Have you verified that your WiFi access point is still visible to other devices (like a laptop or smartphone) and offers a reasonably strong signal?

12 (edited by bobsz 2014-01-08 15:03:40)

Re: SHOUTcast radio search function b0rken?

I hate to make such a low-tech guess, but did you re-boot your wi-fi modem/router? I had a problem with one device not connecting a while back. It was explained to me that the router still "thought" the device was connected, so wouldn't let it connect again. Just turning the router off for a while then back on let the wi-fi "find" the device again.

BTW, you posted your question in a thread here about Shoutcast radio, not about general connection problems. No big deal, but if others don't reply, maybe start a new topic under this Service/repair section. At the start of the section, click on "Post new topic" on the top right of the pages. If you call it something like "Chumby won't connect to wi-fi" you might get some more savvy responderd than a troller like me.

Re: SHOUTcast radio search function b0rken?

Since you're getting a MAC, and you're seeing your access points, that says the problem is not with the network adapter itself (broken or loose).

"Failed to get IP" address is a DHCP problem - for some reason, your router is not allocating an IP on your local network.  This can happen if you have DHCP disabled (the device would be getting the public IP for your router, and there's typically only one available at a time), or you have hit the limit on the number of devices that can be assigned IPs, or the signal is very weak, there's some other problem.

One suggestion is to take the device to another similar residential-type network and see if it connects there.

Re: SHOUTcast radio search function b0rken?

Usually, setting up a static IP with my Chumby fixes connection problems, so you may want to do this as well.