1 (edited by Steevo 2016-04-28 10:28:12)

Topic: Won't get number from dhcp

Well, I just thought I would ask this.
I have an I3 on my desk. Mostly I use it to play Pandora.
Today, it was not connected. I tried to connect it and it asked "new or existing network".  Odd. I told it existing, and  it said chumby.com was unreachable. It can see the network, in fact the AP is 5' from it.

I tried various times, rebooted it, rebooted the access point, all kinds of things.
Wouldn't connect to either of my two APs.

So I gave it a static IP, and it connected immediately.
It seems it was unable to get a number from DHCP. Everything else can, but not this Chumby.

I have Engenius APs. I had an older model that I had this problem with, but this new one has been here a year and never a problem until today.

Does anyone know why this could be?
It's working now but it seems so odd.  DHCP problem.

Re: Won't get number from dhcp

Hmm, interesting. I have seen that before when the AP was configured to only issue a range of IPs or limited to a maximum number of unique MAC addresses, and for some reason, ran out.

I think an I3 will accept a USB keyboard and bring up a console, like the C1.  You might be able to get more info about the failure.

Re: Won't get number from dhcp

I was just going to say it ran out of addresses.  When it does, it doesn't error, it just doesn't respond.

Why not just leave you toy on a static address?

Re: Won't get number from dhcp

I have had a similar issue with the AP that comes with my AT&T U-Verse Internet connection; sometimes the Chumby would get an IP and sometimes it just wouldn't without doing a double power-cycle (and come to think of it that was probably with a static IP). Upgrading to a Linksys device (to also add 5Ghz channels for other devices) has made a major difference, now my Chumby devices always boot up first time.