Topic: ethernet adapter freezes my hackerboard

Hi all,

I've just gotten my shiny new hackerboard from Adafruit.  However, when I plug in the ethernet adapter that I also purchased from them, instead of seeing it enumerate, the board just stops responding!

Any ideas as to why this could be?


Re: ethernet adapter freezes my hackerboard

! thats not good. do you mind trying a different USB port? do other USB devices work on that port? is it well powered? those ethernet dongles are mega-power-hungry

Re: ethernet adapter freezes my hackerboard

oh yeah, i forgot to post back here yesterday.

it works, but *only* when plugged into port USB2.

i can read my usb key from at least port USB1, haven't had a chance to try it with the other ones yet.

i'm powering it with the wall plug that ya'll sell.

Re: ethernet adapter freezes my hackerboard

Well, at least it works somewhat smile
I will have to defer to the hardware experts for debugging advice since it sounds like it -ought- to work with any port.
you could try to measure the VCC on the USB ports when you plug in the ethernet dongle with a multimeter. is it 5.0 or more like 4.5v?

5 (edited by pandrani 2010-10-03 17:44:31)

Re: ethernet adapter freezes my hackerboard

Try using a powered USB hub and plug the Ethernet dongle into that. I had the same freeze problem initially and just tried the USB hub and now the Chumby board doesn't freeze when I plug in my Ethernet dongle.

Seems to be power related. I suspect either the power adapter or something on the Chumby board can't supply enough power as ladyada seems to suspected in the post above.

Re: ethernet adapter freezes my hackerboard

Be careful with the powered USB hub though... It seems to be back powering the Chumby board over USB somehow.  When I unplug the PSP style power adapter from the Chumby board the Vin and +5 LEDs on the board are still lit. The board freezes when I do that though.

Not sure if this is a bad thing or not. I was even able to get the board to partially boot without the PSP adapter plugged in. Only had the powered USB hub plugged into one of the UBS ports (USB2).

Re: ethernet adapter freezes my hackerboard

I've bought the same USB Ethernet adaptor and have only tried USB0 so far.  Both time I plugged it in the board with Linux running, the board rebooted, but in dmesg I saw that it enumerated during the reboot.

I just leave it in now and upon powering the board it just works fine... so maybe a rush current issue when inserting it and placing a large 5V capacitor near these USB ports could help..  (My wallwart is 5V@2A)

(Haven't triend if USB1 or 2 is immune to this yet...)