Topic: Sony Dash (w/Chumby) time is always wrong

I have 2 Sony Dash HID-C10 that I installed the Chumby software on.  The time is always wrong on them.  One is 9-minutes slow, the other one is 4-minutes fast.  Both have working internet connections.

Any way to fix this?

Re: Sony Dash (w/Chumby) time is always wrong

The dash is supposed to try to sync with network time at around 3 am each day.  It uses NTP to do this - you might check to see if that's blocked on your network or by your ISP somehow.  The linux command it issues is:

ntpdate pool.ntp.org

It will do this only if the contents of the file "/psp/use_ntp" is "1".

"pool.ntp.org" typically redirects to some random time server, it's remotely possible you're getting ones that are incorrect.

Re: Sony Dash (w/Chumby) time is always wrong

I guess that's the problem, I'm getting:

[root@tango3 ~]# ntpdate pool.ntp.org
 3 Sep 21:01:53 ntpdate[4347]: no server suitable for synchronization found
[root@tango3 ~]#

my use_ntp file does contain 1.
I don't think it should be blocked.  I have my ISP router in DMZ mode which should bypass any firewall, I thought.

Re: Sony Dash (w/Chumby) time is always wrong

My guess is that your ISP is blocking NTP.

Re: Sony Dash (w/Chumby) time is always wrong

That would make sense, but it seems like my PC on the same network is able to connect:

C:\WINDOWS\system32>w32tm /stripchart /computer:pool.ntp.org /dataonly /samples:5
Tracking pool.ntp.org [173.0.156.209:123].
Collecting 5 samples.
The current time is 9/4/2018 8:37:10 AM.
08:37:10, +01.2556732s
08:37:12, +01.2552709s
08:37:14, +01.2556781s
08:37:16, +01.2562051s
08:37:18, +01.2570246s

Seems like it's working, if that's an accurate test.

Re: Sony Dash (w/Chumby) time is always wrong

Hmmm, I don't know enough about Windows, but it certainly *looks* like you're getting through on your PC.

The script that syncs time on the dash is the same one as all of the other chumby devices, except that some of the chumby devices use time.chumby.com, which is just an alias for pool.ntp.org.  The chumby patches for dash do not replace this script, so whatever's going on would have affected even the unmodified dash.

On your dash, try using ntpdate with the IP you got on Windows resolving pool.ntp.org - perhaps there's a name resolution problem on the dash?

Re: Sony Dash (w/Chumby) time is always wrong

Seems like it works when I use the -u switch.  Here's what I tried:

[root@tango3 ~]# ntpdate pool.ntp.org
 4 Sep 11:39:56 ntpdate[6920]: no server suitable for synchronization found
[root@tango3 ~]# ntpdate -q pool.ntp.org
server 69.195.159.158, stratum 2, offset 517.109702, delay 0.07394
server 173.230.144.109, stratum 2, offset 517.111545, delay 0.10028
server 66.70.234.51, stratum 3, offset 517.111906, delay 0.09090
server 23.239.24.67, stratum 16, offset 517.107179, delay 0.06207
 4 Sep 11:40:23 ntpdate[6998]: step time server 69.195.159.158 offset 517.109702 sec
[root@tango3 ~]# ntpdate -u pool.ntp.org
 4 Sep 11:49:44 ntpdate[7109]: step time server 103.105.49.148 offset 517.113160 sec

Documentation says that switch opens an unprivileged port.  "This is most useful when behind a firewall that blocks incoming traffic to privileged ports, and you want to synchronise with hosts beyond the firewall."

I don't really know what that means, but seems like firewall is still blocking something, but I can get around it by using an unprivileged port.  Is it possible to change the Dash to use an unprivileged port by default?

Re: Sony Dash (w/Chumby) time is always wrong

What you'd have to do is copy the sync_time.sh script from /usr/chumby/scripts to /psp and change crontab in /psp to use it instead of the built-in one (which is a read-only filesystem).  You can then edit the script to add the appropriate switch.

EDIT - I don't have a dash with me at the moment, but i *think* the script itself can take a switch which is passed to ntpdate - if so, it might just require a minor edit to the crontab.